We are investigating a partial degradation of services

Minor incident Customer Dashboard
2021-03-26 14:17 UTC · 34 minutes

Updates

Resolved

This issue has been resolved and all systems are operating at full capacity. Thank you for your patience as we work through this.

March 26, 2021 · 14:52 UTC
Issue

We have detected issues and we are currently investigating, we’ll update you soon.

March 26, 2021 · 14:18 UTC

← Back